Sanwa 29e31s-b No Picture-total black

For monitor related issues
User avatar
nem
Posts: 1924
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Sanwa 29e31s-b No Picture-total black

Post by nem »

I have a 29e31s right now on the bench. Poor and dull colors, or even no color at all? It's almost certainly the tube on these. I think the chassis isn't actually half bad, but the Shanghai Novel tubes are the worst I've ever seen. The tube I have now was almost pitch black, you could maybe make out some faint lines. You turned the voltage on the screen pot and background turned dark grey. I connected a CRT analyzer / rejuvenator to it and the needles barely moved even with the voltage turned up.

I rejuvenated all three guns and it's looking somewhat OK now. The problem is I don't know if the effect will last or if it will start dimming again in 50-100 hours.

I think I have six of these monitors now, and I would say 5 tubes have or have had similar issues. One has a completely dead gun, two are clearly dying, and two are OK. Can't say yet of this sixth one. Although considering how bad it was, I don't have high hopes.

As for the chassis, three have had flybacks replaced (the original flyback were working, but the picture looked like an hourglass) and all six have been recapped.
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

Good morning .
Let me introduce myself: I am the owner and technician of the Tecknoservice service center in Spain.
I read your comments.
Even if my English is bad I will try to answer some comments.
I read that my prices are more expensive than the others.
I also used Taobab initially but the products were very poor and needed constant changes.
Since I mostly do repairs across Europe, I was unable to deliver unreliable chassis to my customers.
About a few years ago I made contact through a trusted person in China with a large manufacturing company.
I started sending the original Flybacks and getting them copied. (I have almost all the flibacks).
We have to consider that for each Flyback I had to bear sending costs + sample return costs, try it for at least a week with the video game running and then place the order (minimum 500) pieces.
So my costs are significantly higher.
I would like to add that even after the sale I offer free assistance and help to all my customers if they have problems.
I ship on the same day with reliable couriers and reach all European destinations in a maximum time of 3/4 days.
Having said that I do not say that mine are superior to others but for my job I prefer to use my products then if some customer buys them I am pleased.
However, I am always available for any technical questions or doubts.
Thank You
Tecknoservice
User avatar
nem
Posts: 1924
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Sanwa 29e31s-b No Picture-total black

Post by nem »

If you have had these flybacks made, then you're absolutely within reason to ask whatever price you want for them. You pay the costs, you name your price. I remember you buying up completely stock of products on Taobao, that's why I had a negative opinion on you. Thank you for correcting me! And good job on making the effort! It's great that these chassis are getting repaired instead of being junked.
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

Maybe someone else bought flyback on Taobab. I placed an order of 50 pieces in January 2019 and they only sent me 4. I lost the money and was unable to recover it.
I buy from Diemen that I have it a few kilometers from my house as far as European chassis are concerned.
For all US and Japanese chassis I have this company that produces hospital laser transformers that produces them for me.
They will not be perfect but I am satisfied with them.
psyko44
Posts: 16
Joined: November 18th, 2017, 2:56 pm
Location: france
eBay: daedalus4456

Re: Sanwa 29e31s-b No Picture-total black

Post by psyko44 »

TECKNOSERVICE wrote:
April 18th, 2020, 3:34 pm

I buy from Diemen that I have it a few kilometers from my house as far as European chassis are concerned.
so diemen do this flyback for naomi chassis?
i can't found this reference on their website :/
User avatar
nem
Posts: 1924
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Sanwa 29e31s-b No Picture-total black

Post by nem »

psyko44 wrote:
April 30th, 2020, 4:35 pm
so diemen do this flyback for naomi chassis?
i can't found this reference on their website :/
HR Diemen 46274 will work on a 29e31s. You have to swap R447 to a 56k resistor (original is 33k).

The image quality isn't perfect, but it works. I've had it running for over a year.
User avatar
grantspain
Tech Head
Posts: 4572
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Sanwa 29e31s-b No Picture-total black

Post by grantspain »

efiter no longer stock those flybacks
psyko44
Posts: 16
Joined: November 18th, 2017, 2:56 pm
Location: france
eBay: daedalus4456

Re: Sanwa 29e31s-b No Picture-total black

Post by psyko44 »

so there is a real problem...
nobody build today this flyback?

in taoboa you found flyback with bsc24 - 0107 ref, but there is others number ref written on it, and they haven't the same shape that TECKNOSERVICE sale on ebay.
User avatar
grantspain
Tech Head
Posts: 4572
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Sanwa 29e31s-b No Picture-total black

Post by grantspain »

get the one from tecknoservice, costs a little more but known to work
psyko44
Posts: 16
Joined: November 18th, 2017, 2:56 pm
Location: france
eBay: daedalus4456

Re: Sanwa 29e31s-b No Picture-total black

Post by psyko44 »

grantspain wrote:
April 30th, 2020, 6:48 pm
get the one from tecknoservice, costs a little more but known to work
i had 12 naomi, and 9 in shangai novel ... so, no i can t/don't want to buy 9 * 70€ just for these cab.
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

Unfortunately, I'm not asking too much. There are costs that I have to face.
I earn a maximum of 10/15 euros on a transformer.
And for a company that has expenses, they are very few.
If you buy one, maybe it costs you less.
When I place orders I use DHL as a freight forwarder and for 100 Flybacks I pay about 390 euros for shipping.
When they arrive I pay 21% VAT plus about 150 euros in customs clearance fees. Then I have to sell them.
I have to pay ebay commissions (8%), paypal commissions (4.5%) , box to put in and finally I pay sales taxes with my company.
It is difficult to explain, but when I sell a transformer for 70 euros, more than half are wasted costs. The real cost of the transformer at the factory does not exceed 30 euros.
Such as the Pandora. I stopped selling because they cost me almost double what they sell on Ali.
User avatar
nem
Posts: 1924
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Sanwa 29e31s-b No Picture-total black

Post by nem »

TECKNOSERVICE wrote:
May 1st, 2020, 9:14 pm
I have to pay ebay commissions (8%), paypal commissions (4.5%)
Is there some reason why you insist on selling on eBay / using Paypal? Make a FS post on here and ask for SEPA bank transfers (they're free). 60 euros is already way more enticing than 70 euros.
User avatar
DracoTom
Posts: 10
Joined: April 30th, 2020, 7:45 pm
Location: France
eBay: hdnetwork
Initials: TOM

Re: Sanwa 29e31s-b No Picture-total black

Post by DracoTom »

Hello all,
I'm the owner of a Naomi universal cabinet with a 29E31S chassis inside.
Sadly i have an issue, black screen on it.
I changed the flyback before and it worked good but now, nothing.
When i open it, i ear the little 'click' who say the power is on but nothing much.
I would like to know if anybody have an idea how to begin to search, does it's possible to test the flyback power ?
Any help is welcome, thank you!!
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

nem wrote:
May 2nd, 2020, 9:59 am
TECKNOSERVICE wrote:
May 1st, 2020, 9:14 pm
I have to pay ebay commissions (8%), paypal commissions (4.5%)
Is there some reason why you insist on selling on eBay / using Paypal? Make a FS post on here and ask for SEPA bank transfers (they're free). 60 euros is already way more enticing than 70 euros.
But I can sell 60 euros outside ebay. I already sell them to dozens of my customers.
Just today I sold 5 MSU1FUS11 for Nanao MS 2931.
I have many clients who contact me privately.
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

DracoTom wrote:
May 2nd, 2020, 11:39 am
Hello all,
I'm the owner of a Naomi universal cabinet with a 29E31S chassis inside.
Sadly i have an issue, black screen on it.
I changed the flyback before and it worked good but now, nothing.
When i open it, i ear the little 'click' who say the power is on but nothing much.
I would like to know if anybody have an idea how to begin to search, does it's possible to test the flyback power ?
Any help is welcome, thank you!!
These chassis often go into protection even for stupid things.
I advise you to check the IC of the vertical circuit.
If it doesn't work, it won't start your chassis.
User avatar
DracoTom
Posts: 10
Joined: April 30th, 2020, 7:45 pm
Location: France
eBay: hdnetwork
Initials: TOM

Re: Sanwa 29e31s-b No Picture-total black

Post by DracoTom »

TECKNOSERVICE wrote:
May 2nd, 2020, 8:32 pm
DracoTom wrote:
May 2nd, 2020, 11:39 am
Hello all,
I'm the owner of a Naomi universal cabinet with a 29E31S chassis inside.
Sadly i have an issue, black screen on it.
I changed the flyback before and it worked good but now, nothing.
When i open it, i ear the little 'click' who say the power is on but nothing much.
I would like to know if anybody have an idea how to begin to search, does it's possible to test the flyback power ?
Any help is welcome, thank you!!
These chassis often go into protection even for stupid things.
I advise you to check the IC of the vertical circuit.
If it doesn't work, it won't start your chassis.
Thanks for your answer!!
Well, i will look at it and i will tell you:)
On this chassis, it look like the screen getting blank for any issue, that make really difficult to diagnose...
Thanks for your help!!

By the way, on this chassis, if anybody have drooling colors when you try to make much colorfull or with the contrast, there is some resistors to change on the yoke to slove this problem, if you wanna know, i'll post a picture.
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

DracoTom wrote:
May 2nd, 2020, 9:53 pm
TECKNOSERVICE wrote:
May 2nd, 2020, 8:32 pm
DracoTom wrote:
May 2nd, 2020, 11:39 am
Hello all,
I'm the owner of a Naomi universal cabinet with a 29E31S chassis inside.
Sadly i have an issue, black screen on it.
I changed the flyback before and it worked good but now, nothing.
When i open it, i ear the little 'click' who say the power is on but nothing much.
I would like to know if anybody have an idea how to begin to search, does it's possible to test the flyback power ?
Any help is welcome, thank you!!
These chassis often go into protection even for stupid things.
I advise you to check the IC of the vertical circuit.
If it doesn't work, it won't start your chassis.
Thanks for your answer!!
Well, i will look at it and i will tell you:)
On this chassis, it look like the screen getting blank for any issue, that make really difficult to diagnose...
Thanks for your help!!

By the way, on this chassis, if anybody have drooling colors when you try to make much colorfull or with the contrast, there is some resistors to change on the yoke to slove this problem, if you wanna know, i'll post a picture.
Unfortunately for work I can't follow all posts here.
Of these Sanwa I repair dozens a month.
If I can help you in my available time you can ask me.
User avatar
DracoTom
Posts: 10
Joined: April 30th, 2020, 7:45 pm
Location: France
eBay: hdnetwork
Initials: TOM

Re: Sanwa 29e31s-b No Picture-total black

Post by DracoTom »

TECKNOSERVICE wrote:
May 2nd, 2020, 10:12 pm
DracoTom wrote:
May 2nd, 2020, 9:53 pm
TECKNOSERVICE wrote:
May 2nd, 2020, 8:32 pm


These chassis often go into protection even for stupid things.
I advise you to check the IC of the vertical circuit.
If it doesn't work, it won't start your chassis.
Thanks for your answer!!
Well, i will look at it and i will tell you:)
On this chassis, it look like the screen getting blank for any issue, that make really difficult to diagnose...
Thanks for your help!!

By the way, on this chassis, if anybody have drooling colors when you try to make much colorfull or with the contrast, there is some resistors to change on the yoke to slove this problem, if you wanna know, i'll post a picture.
Unfortunately for work I can't follow all posts here.
Of these Sanwa I repair dozens a month.
If I can help you in my available time you can ask me.
No problem, for sure, i understand it :)

In my side, i tested the vertical IC Q303 LA7838, i tested on two chassis for comparaison and i have pretty the same mesurement on both.
I tested, resistors and trnansistors around , not found something, always the same on both chassis.
I tested too the horizontal IC Q402 LA7856 and as the current, all seems to be okay.
Thanks again for your help!!
User avatar
TECKNOSERVICE
Posts: 13
Joined: April 18th, 2020, 12:30 pm
Location: Spain
eBay: tecknoservice-es
Initials: TKS
Contact:

Re: Sanwa 29e31s-b No Picture-total black

Post by TECKNOSERVICE »

DracoTom wrote:
May 3rd, 2020, 12:47 pm
TECKNOSERVICE wrote:
May 2nd, 2020, 10:12 pm
DracoTom wrote:
May 2nd, 2020, 9:53 pm


Thanks for your answer!!
Well, i will look at it and i will tell you:)
On this chassis, it look like the screen getting blank for any issue, that make really difficult to diagnose...
Thanks for your help!!

By the way, on this chassis, if anybody have drooling colors when you try to make much colorfull or with the contrast, there is some resistors to change on the yoke to slove this problem, if you wanna know, i'll post a picture.
Unfortunately for work I can't follow all posts here.
Of these Sanwa I repair dozens a month.
If I can help you in my available time you can ask me.
No problem, for sure, i understand it :)

In my side, i tested the vertical IC Q303 LA7838, i tested on two chassis for comparaison and i have pretty the same mesurement on both.
I tested, resistors and trnansistors around , not found something, always the same on both chassis.
I tested too the horizontal IC Q402 LA7856 and as the current, all seems to be okay.
Thanks again for your help!!
Unfortunately it is not easy to find a problem remotely. I can give you some advice.
Disconnect the plug that goes on the CRT board (Nek board).
You have to unplug the one that brings the 180 volts to the colors.
It can happen that a diode on the color transistors or a transistor goes short-circuiting and sends the entire chassis protection.
User avatar
DracoTom
Posts: 10
Joined: April 30th, 2020, 7:45 pm
Location: France
eBay: hdnetwork
Initials: TOM

Re: Sanwa 29e31s-b No Picture-total black

Post by DracoTom »

TECKNOSERVICE wrote:
May 3rd, 2020, 6:31 pm
DracoTom wrote:
May 3rd, 2020, 12:47 pm
TECKNOSERVICE wrote:
May 2nd, 2020, 10:12 pm


Unfortunately for work I can't follow all posts here.
Of these Sanwa I repair dozens a month.
If I can help you in my available time you can ask me.
No problem, for sure, i understand it :)

In my side, i tested the vertical IC Q303 LA7838, i tested on two chassis for comparaison and i have pretty the same mesurement on both.
I tested, resistors and trnansistors around , not found something, always the same on both chassis.
I tested too the horizontal IC Q402 LA7856 and as the current, all seems to be okay.
Thanks again for your help!!
Unfortunately it is not easy to find a problem remotely. I can give you some advice.
Disconnect the plug that goes on the CRT board (Nek board).
You have to unplug the one that brings the 180 volts to the colors.
It can happen that a diode on the color transistors or a transistor goes short-circuiting and sends the entire chassis protection.
That's so nice to you to help me and i take your advices as a precious treasure!

So that the plug "P901" who out from the power supply of the chassis i guess?
if i unplug it, i need to power on the chassis? It can have any result?
Thanks :)
Post Reply