Two MS9's kickin the bucket in a month...

For monitor related issues
Post Reply
User avatar
atro
Posts: 43
Joined: April 3rd, 2016, 9:20 pm
Location: Portugal
eBay: atro.pt
Initials: RB

Two MS9's kickin the bucket in a month...

Post by atro » August 24th, 2019, 6:33 pm

Hi there!

Unfortuatelly the half of the Nanao's MS9 I have are crapping out.

Last year two of them got revived with collapse issues and/or recapping. However, these two remaining chassis (one tube, Hitachi) are f)(%ing up.

Not really sure were the problem's coming from any of them:





On the later, I believe some color transistor might have gone funky. Somehow I don't get how the geometry on the upper part of the screen went so screwed up. This one got bad first and I swapped it with the chassis of the first video, where the geometry was mostly spot on before crapping out to that green screen. :problem:

Any lead on any of these issues? Thanks in advance. :awe:

User avatar
PrincessPrinPrin
Posts: 461
Joined: April 7th, 2011, 4:00 pm
Location: Pordenone, Italy
eBay: *mkl*
Initials: MKL

Re: Two MS9's kickin the bucket in a month...

Post by PrincessPrinPrin » August 25th, 2019, 12:18 pm

Put the neckboard of the second chassis on the first chassis and you will probably have a working chassis.
Im running games with a vga to tv converter on my Shangai Novel, with composite and it looks amazing, Im not interested in RGB or Scart.

- anonymous

User avatar
atro
Posts: 43
Joined: April 3rd, 2016, 9:20 pm
Location: Portugal
eBay: atro.pt
Initials: RB

Re: Two MS9's kickin the bucket in a month...

Post by atro » August 27th, 2019, 7:24 pm

Thanks.

I'm gonna order parts and redo the whole neckboard.

User avatar
LegoYoda
Posts: 134
Joined: December 21st, 2012, 1:27 pm
Location: South East UK
eBay: neomonster
Initials: AGD

Re: Two MS9's kickin the bucket in a month...

Post by LegoYoda » September 5th, 2019, 1:38 pm

They are worth repairing.... whatever you do, dont chuck them!
Alec
----------------------------------------
Owning a Blast City: Fixing and Repairing -http://retrogamingstuff.wordpress.com/

User avatar
copados33
Posts: 452
Joined: March 20th, 2013, 1:30 pm
Location: Uruguay South America
eBay: psycho-q

Re: Two MS9's kickin the bucket in a month...

Post by copados33 » September 7th, 2019, 10:02 pm

Faulty zenner diodes on the neckboard on both chassis, on the first one the screen adjustment is either too high, or no video signal.

User avatar
atro
Posts: 43
Joined: April 3rd, 2016, 9:20 pm
Location: Portugal
eBay: atro.pt
Initials: RB

Re: Two MS9's kickin the bucket in a month...

Post by atro » September 10th, 2019, 7:09 pm

copados33 wrote:
September 7th, 2019, 10:02 MP
Faulty zenner diodes on the neckboard on both chassis, on the first one the screen adjustment is either too high, or no video signal.
it has signal! if you check closely, you can see the KOF98 intro fading out. Also, screen volts is not too high. Ordered some parts, they have to come yet.

Post Reply