Nanao MS9-29 (05A00675C2) dead

For monitor related issues
Post Reply
User avatar
frsj8112
Posts: 90
Joined: April 11th, 2012, 6:06 pm
Location: Sweden
eBay: frsj8112

Nanao MS9-29 (05A00675C2) dead

Post by frsj8112 »

Another MS9 issue

Tested out as non working, had original caps. Went into protection mode after a few seconds.
Recapped, found that C513 near the HOT was open.
HOT was also shorted, replaced

Retested, still going into protection mode.
Pin 2 of flyback has been desoldered and isolated and light bulb added to pins of C515 as dummy load.

Retested, light bulb lights up but chassis shuts down and the light goes out.

Any pointers besides looking for solder blobs, cold solder joints?

@grantspain
User avatar
frsj8112
Posts: 90
Joined: April 11th, 2012, 6:06 pm
Location: Sweden
eBay: frsj8112

Re: Nanao MS9-29 (05A00675C2) dead

Post by frsj8112 »

@PrincessPrinPrin ? :cry:
User avatar
PrincessPrinPrin
Posts: 564
Joined: April 7th, 2011, 4:00 pm
Location: Pordenone, Italy
eBay: *mkl*
Initials: MKL

Re: Nanao MS9-29 (05A00675C2) dead

Post by PrincessPrinPrin »

Sounds like a problem in the power supply. Check the B+ diodes on the output (D951, D952, D956), the caps (C951, C952, C953). If they're OK check the primary side.
User avatar
frsj8112
Posts: 90
Joined: April 11th, 2012, 6:06 pm
Location: Sweden
eBay: frsj8112

Re: Nanao MS9-29 (05A00675C2) dead

Post by frsj8112 »

Long time, no see

I've looked at this chassis again and verified the diodes and caps mentioned by @PrincessPrinPrin and they all check out OK.

I tried the light bulb test again and is still as before, light goes out after a second or two.

I can't find any cold solder joints or anything else real obvious.
Post Reply