MS9-29 chassis problem - faint vertical line on left side screen

For monitor related issues
Post Reply
chriszhxi
Posts: 14
Joined: October 10th, 2017, 6:03 am
Location: US
eBay: chriszhxi

MS9-29 chassis problem - faint vertical line on left side screen

Post by chriszhxi »



The line is near the turtles from top to bottom.

This picture is from another person, posted on another forum but got no answer, that guy did a recap and problem was still there.

My problem is exactly the same. The position and shape of the line is identical, must be something specific on the chassis.

Anyone know how to fix it?
User avatar
grantspain
Tech Head
Posts: 4746
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by grantspain »

did they replace all the caps or just certain caps, there are a number caps around the rgb ic that will cause this exact issue
chriszhxi
Posts: 14
Joined: October 10th, 2017, 6:03 am
Location: US
eBay: chriszhxi

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by chriszhxi »

grantspain wrote: June 19th, 2022, 12:25 am did they replace all the caps or just certain caps, there are a number caps around the rgb ic that will cause this exact issue
I don't know, that post was 10 years ago from google search.

Can you tell me which caps could cause this issue? Thanks.
User avatar
grantspain
Tech Head
Posts: 4746
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by grantspain »

211,212,213 2.2uf 50v
221 100uf 16v
201,202,203 47uf 25v
220 470uf 16v
107 22uf 50v
replace 101 if electrolytic

all the above are around u201
User avatar
grantspain
Tech Head
Posts: 4746
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by grantspain »

also i would like to add if any of those caps are indeed bad then its likely the rest of the caps are bad or on their way
i would suggest just changing those first to see if its removes that line
chriszhxi
Posts: 14
Joined: October 10th, 2017, 6:03 am
Location: US
eBay: chriszhxi

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by chriszhxi »

grantspain wrote: June 19th, 2022, 11:14 am 211,212,213 2.2uf 50v
221 100uf 16v
201,202,203 47uf 25v
220 470uf 16v
107 22uf 50v
replace 101 if electrolytic

all the above are around u201
These looks good from visual inspect, but I will try replace them first, thanks.

what's the model of 101?
User avatar
grantspain
Tech Head
Posts: 4746
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by grantspain »

c101 is sometimes 1uf but there were factory mods on this cap that replaced with a polyester type
chriszhxi
Posts: 14
Joined: October 10th, 2017, 6:03 am
Location: US
eBay: chriszhxi

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by chriszhxi »

grantspain wrote: June 19th, 2022, 1:26 pm c101 is sometimes 1uf but there were factory mods on this cap that replaced with a polyester type
yes, that's what on my chassis, the only number I can read on it is 104.

What should I use to replace it?
User avatar
grantspain
Tech Head
Posts: 4746
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by grantspain »

leave that cap as it will not fail
chriszhxi
Posts: 14
Joined: October 10th, 2017, 6:03 am
Location: US
eBay: chriszhxi

Re: MS9-29 chassis problem - faint vertical line on left side screen

Post by chriszhxi »

grantspain wrote: June 19th, 2022, 11:14 am 211,212,213 2.2uf 50v
221 100uf 16v
201,202,203 47uf 25v
220 470uf 16v
107 22uf 50v
replace 101 if electrolytic

all the above are around u201
I took off all small caps on the right side of chassis and measured them one bye one, caps are all good, but I found 3 caps are not what they are suppose to be according to the lists below.
https://www.jammarcade.net/files/Docume ... s_list.pdf
https://arcademonitor.com/arcade-monito ... nao-ms9-29

C958 suppose to be 22uF 50V, is 47uF 16V, I can tell it's been replaced before, with a different brand than Nichicon.
C408 suppose to be 100uF 35V, is 100uf 25v, with a different brand.

The most suspicious one is
C451 suppose to be 22uF 50V, is 1uf 50v, but it's a Nichicon and seems not be replaced before.

With my very limited knowledge of circuit, the first two caps should somehow work even they have different specs as long as they are good.

Since the guy I mentioned before had the exact same issue, I suspect that C451 might be a factory mistake?

Anyway, I replaced all the caps I took off according to the list, the line is gone.
Post Reply