Blast City with Blurry Screen For About 5 Minutes

Arcade cabinet hardware and accessories
Post Reply
Samelak
Posts: 24
Joined: February 15th, 2019, 11:02 am
Location: Japan
eBay: Samelak

Blast City with Blurry Screen For About 5 Minutes

Post by Samelak » March 22nd, 2020, 5:49 am

I've been trying to figure out why my Blast City has a blurry screen after powering up. I've tried a NANAO 2930 monitor and MS-9 monitor with similar results. I thought it might be the harness connections at the I/O board, but I swapped in a spare harness with the same results. I don't have a spare I/O board so I can't verify if that is it. I thought maybe those old caps on there are dried out. I tried swapping them out, but I have no idea what kind of solder Sega used, but the board is an absolute pain to desolder the caps from. I had to pull the caps off and desolder the legs. Unfortunately it left solder behind in the holes and the solder doesn't want to come out for the new caps to go in. Could use some ideas and now looking for a replacement I/O board.

User avatar
DaveyD
Posts: 295
Joined: December 9th, 2014, 7:14 am
Location: Grimsby, UK
eBay: Dr_Daph
Initials: DPD

Re: Blast City with Blurry Screen For About 5 Minutes

Post by DaveyD » March 22nd, 2020, 9:46 am

Did you melt in some new solder? As this helps dilute the older solder

Samelak
Posts: 24
Joined: February 15th, 2019, 11:02 am
Location: Japan
eBay: Samelak

Re: Blast City with Blurry Screen For About 5 Minutes

Post by Samelak » March 22nd, 2020, 7:32 pm

Tried reflowing with new solder. Personally I don't think its just regular solder they used on it. I've done a lot soldering on a variety of PCBs and never had such trouble getting components out.

Post Reply