Virtua Racing freezes

PCB problems and fixes
Post Reply
User avatar
meyerli
Posts: 138
Joined: February 28th, 2012, 4:06 am
Location: Lakeside, Switzerland
eBay: meyerli0
Initials: MAN

Virtua Racing freezes

Post by meyerli » June 26th, 2019, 6:19 pm

Hi all

On my Virtua Racing Twin the left game is freezing after around half an hour being on: Sound stops, button lights go off and screen freezed.
Power it off and on again freeze happens after a few seconds. Waiting for cooling down (e.g. retry next day) and power on it takes again around half an hour till Freeze.

My first Intention was a heating problem so checked all the fans but they are running.
Replaced the game board (full board including Rom, cpu and communication board) but issue still appears.
Swapped Input/Output board between P1 and P2. Nothing changes.

What else could cause such freezes? Assume if the power supply would be faulty that game goes off completely instead of freezing?

User avatar
Hydreigon
Posts: 40
Joined: December 9th, 2018, 5:48 pm
Location: Milwaukee, WI
eBay: hydreigon223
Initials: HYD

Re: Virtua Racing freezes

Post by Hydreigon » June 26th, 2019, 6:32 pm

Have you swapped either the fans or power supplies on both sides to see if the issue switches? I'd also check voltages coming from both PSUs as well. Most likely either too much voltage causing the boards to heat quicker or the fan is worn and isn't supplying the proper airflow.

That is the first thing I check when it comes to situations like this.

User avatar
meyerli
Posts: 138
Joined: February 28th, 2012, 4:06 am
Location: Lakeside, Switzerland
eBay: meyerli0
Initials: MAN

Re: Virtua Racing freezes

Post by meyerli » June 26th, 2019, 7:16 pm

Thanks, will try this and provide feedback. Hopefully before weekend.

User avatar
meyerli
Posts: 138
Joined: February 28th, 2012, 4:06 am
Location: Lakeside, Switzerland
eBay: meyerli0
Initials: MAN

Re: Virtua Racing freezes

Post by meyerli » June 29th, 2019, 6:25 pm

Swapped the two fans next to power supplies and works already much better. Had it run today for around 1.5 hours without any freezes. Maybe it helped also that I've cleaned the fans a little. Will run it a bit longer when having the chance.

Thanks for your good advice :)

Post Reply