Sengoku Ace PCB not working...

PCB problems and fixes
Post Reply
Benimaru
Posts: 41
Joined: October 12th, 2018, 8:23 pm
Location: Germany
eBay: extension55
Initials: PDG

Sengoku Ace PCB not working...

Post by Benimaru » February 15th, 2019, 3:27 pm

Like the classic german saying: "Haste Scheisse am Schuh, haste Scheisse am Schuh"
After receiving a faulty MS3 Cart yesterday, my Sengoku Ace PCB, which arrived today, is also not working...
After firing it up, the only sign of life is the "Warning" screen. After that, the screen remains black. Voltage is 4,67, there are no damages to the board.
Where should I start?

User avatar
RMRM
Posts: 488
Joined: April 20th, 2013, 4:45 pm
Location: Portugal

Re: Sengoku Ace PCB not working...

Post by RMRM » February 15th, 2019, 3:47 pm

You should start by feeding 5V to the PCB, that's the most obvious test to do. Start from there.

Benimaru
Posts: 41
Joined: October 12th, 2018, 8:23 pm
Location: Germany
eBay: extension55
Initials: PDG

Re: Sengoku Ace PCB not working...

Post by Benimaru » February 15th, 2019, 3:55 pm

Will do, thanks!

User avatar
suicider
Posts: 31
Joined: May 10th, 2010, 2:23 pm
Location: Germany
eBay: suicidekiller

Re: Sengoku Ace PCB not working...

Post by suicider » February 15th, 2019, 7:01 pm

Absolutely what RMRM says. Most PCBs have a good chunk of tolerance concerning the 5V. But some really need a correct or even above voltage input. Had the issue with a Rally Bike PCB which wouldn't start up at all without 5.12V or more.

In diesem Sinne: "Es kommen auch wieder bessere Tage" ;)

Benimaru
Posts: 41
Joined: October 12th, 2018, 8:23 pm
Location: Germany
eBay: extension55
Initials: PDG

Re: Sengoku Ace PCB not working...

Post by Benimaru » February 21st, 2019, 6:29 am

Soooo, I've pushed my AC PSU to the max, resulting in a 4,98V. Still not enough power I guess, as the game still won't work. If I plug in my MVS for example, the voltage is going up to 5,20V. Is the Sengoku Ace PCB so power hungry?
Tried the PCB yesterday on an acquaintances NAC: same problems. Only the warning screen appears, then nothing.
The board itself looks like new, super clean without any signs of corrosion.

Layer
Posts: 153
Joined: March 6th, 2013, 5:38 pm
Location: France

Re: Sengoku Ace PCB not working...

Post by Layer » February 21st, 2019, 7:05 am

Is there a Test mode to view RAM and ROM checks ?

5V voltage should be between 4,80V and 5,15V.
Under 4,80V some TTL dislike that and die. More than 5,15V could be risky but I already tested a few boards at more than 5,25V and they are still working.

Benimaru
Posts: 41
Joined: October 12th, 2018, 8:23 pm
Location: Germany
eBay: extension55
Initials: PDG

Re: Sengoku Ace PCB not working...

Post by Benimaru » February 21st, 2019, 9:58 am

ROM test is visible for a splitsecond before the warning screen is appearing. It shows OK for each step.

Post Reply