Page 3 of 5

Re: [REL] NAOMI Multi-region BIOS

Posted: February 24th, 2015, 8:31 pm
by Jasen
Awesome! This will be much better than installing a region switch :-D I just wish I wasn't moving and deploying in a week... that would make this even better. Thanks LV for sharing at SRK and brining this to my attention; I need to spend more time over here :-D

Re: [REL] NAOMI Multi-region BIOS

Posted: March 5th, 2015, 11:36 am
by tinchen3112
I would like to have this Multi-Bios,too.
Can someone here program this for me?
i sadly have no eprom programmer....

Re: [REL] NAOMI Multi-region BIOS

Posted: May 8th, 2015, 11:35 am
by uncletom
I guess I'm always on a testing rampage. So please tolerate me to report one more issue:

Spawn won't run with the Multi-Region BIOS, I'm sorry to say. The game loads and boots well, but shortly after when the Capcom logo starts to zoom, the games just freezes showing the logo and some "Credit(s) .. " at the bottom.

I've tried it switching to both US and Japanese with the same result, and now I swapped the chip to my default export version 21578H where the game boots and runs flawlessly. I've got two naomi1 running side by side here.

Re: [REL] NAOMI Multi-region BIOS

Posted: May 8th, 2015, 11:37 am
by uncletom
Guten tag on you, Tinchen. I'd be happy to burn you a BIOS-chips. Just get a 27C160 EPROM on ebay and send it to me (message me for address) and I'll do it.

Ok, I just noticed this was a month ago, so you've probably solved it by now.

Re: [REL] NAOMI Multi-region BIOS

Posted: May 12th, 2015, 6:37 am
by p1pkin
uncletom, are you sure good EEPROM was used and it was programmed without errors ? can't reproduce issue here, Spawn works fine for me.

Re: [REL] NAOMI Multi-region BIOS

Posted: May 12th, 2015, 6:43 am
by andygeezer
uncletom wrote:I guess I'm always on a testing rampage. So please tolerate me to report one more issue:

Spawn won't run with the Multi-Region BIOS, I'm sorry to say. The game loads and boots well, but shortly after when the Capcom logo starts to zoom, the games just freezes showing the logo and some "Credit(s) .. " at the bottom.

I've tried it switching to both US and Japanese with the same result, and now I swapped the chip to my default export version 21578H where the game boots and runs flawlessly. I've got two naomi1 running side by side here.
Is it original cart or net boot. You might want to try net boot as sounds like a security issue.

Re: [REL] NAOMI Multi-region BIOS

Posted: May 12th, 2015, 7:25 am
by uncletom
Thanks Andy. Well, I only netboot.

Re: [REL] NAOMI Multi-region BIOS

Posted: November 28th, 2015, 1:01 pm
by Sp33dFr34k
Thank you very much for releasing this bios! Somebody was kind enough to burn it for me. Here's the thing, it works fine in his Naomi, doesn't work at all in mine though. Just boots to a black screen and that is it. I have already replaced the supercap and flat battery just in case but made no difference. Changing the jumpers makes no difference either. Anybody here who can think of something that could be wrong here? I am using both Japanese and EXPORT H bios just fine in combination with carts and netbooting, everything works fine, so should be a small thing I guess, just can't figure out what exactly...

Re: [REL] NAOMI Multi-region BIOS

Posted: November 28th, 2015, 11:15 pm
by Pa0l0ne
Hi all. Is there anyone who can sell me two preprogrammed multibios EPROM?

Re: [REL] NAOMI Multi-region BIOS

Posted: November 30th, 2015, 2:09 am
by Dache
I might be interested in one too, if possible! Mine's an Export currently, wouldn't mind being able to bypass some of the region protected games.

Re: [REL] NAOMI Multi-region BIOS

Posted: November 30th, 2015, 6:49 am
by uncletom
I can program this BIOS for you. PM me your details, I'll get some c160s on ebay and send you.

Postage should be around SEK28 which would be about €3, plus a €1 for the chip.

Re: [REL] NAOMI Multi-region BIOS

Posted: January 30th, 2016, 5:46 pm
by Gakman
Playing with my Virtua Tennis (Power Smash) card on Naomi with your great BIOS, I've discovered you can reach more than these 4 regions using DIP 4 :
OFF OFF OFF = Japan
ON OFF OFF = USA
OFF ON OFF = Export
ON ON OFF = Korea
OFF OFF ON = Australia
ON ON ON = @
OFF ON ON = ?
ON OFF ON = ?

Must test other games to see if the 3 last settings are used.
:D

Re: [REL] NAOMI Multi-region BIOS

Posted: January 31st, 2016, 10:00 am
by uncletom
Yes, well that is awesome.

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 4:19 am
by skate323k137
I have recreated the spawn issue with an original cart, as has another guy. It will freeze at the Capcom logo with a multi bios but boots fine on a regular JP H bios. Does this regardless of if a comm bd is present.

I have burned/verified the multi bios myself, the cart passes test mode check, and I pulled and CRC checked IC22 from the cart as well. I've played the vast majority of the NAOMI library on the motherboards I've tested this on.

It's not a huge problem for me but I'm just posting for posterity sake. BTW, if anyone has a netboot image for SPAWN I wouldn't mind giving it a try to see if it behaves differently than the original cart.

The fellow who noticed this and let me know of the issue (thanks bk2099) says that if you insert a coin before the freeze, the game will boot. I did not verify that myself at this point.

p1pkin, are you using an orig cart or a netboot image? Also if it's an original cart, does it have a rev B sticker? Both of the "problem" carts that won't play well with multi bios are rev b. Also perhaps to reproduce the issue, ensure that no credits are in, as the NAOMI carries those over on reboots.

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 6:41 am
by uncletom
Good stuff there, Skateordie. Prooves I'm not crazy. Here's the netboot file for you.

http://www.albyhus2.se/_eget/SEGA/naomi/spawn.zip

Go rocknroll on it.

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 7:35 am
by p1pkin
skate323k137
can you describe exact sequence of actions leading to Spawn freeze ?

I'm using emulator ;)

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 9:15 am
by uncletom
"The game loads and boots well, but shortly after when the Capcom logo starts to zoom, the games just freezes showing the logo and some "Credit(s) .. " at the bottom."

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 12:46 pm
by Dache
I believe I was able to netboot Spawn without any issues. From what I remember I got it from that Naomi thread on the Neo Arcadia forums. But I've only played it once and it was a while ago because it's a bit ****, so I may have already had credits in the cab when it loaded and avoided any freezing. Can give it another go and confirm though.

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 6:52 pm
by skate323k137
p1pkin wrote:skate323k137
can you describe exact sequence of actions leading to Spawn freeze ?

I'm using emulator ;)
I only had a few moments before work today to continue testing. Basically as others have said... if you boot the game on a NAOMI 1 motherboard without credits in, it freezes as the CAPCOM logo starts to zoom and locks up the system. I can test a NAOMI 2 at a later date just to see.

The netboot image (thanks uncletom) acts the same as my original cartridge.

If you insert a coin at the "This game is only for use in Japan..." screen, it will skip the capcom logo, go straight to the title screen, and the game plays normally. However, if it ever falls into attract mode without credits it will freeze at the CAPCOM logo even if you've already played a round.

Worst case I can pump a bunch of coins in. I like to play the linked cabinet games, and this game has a bunch of extra modes if you link in an extra cabinet or two.

Re: [REL] NAOMI Multi-region BIOS

Posted: March 15th, 2016, 6:57 pm
by p1pkin
ok, got it, I'll look at this issue.

are you sure this not related to I/O ? afaik some games wont work with no coin counters connected or spoofed.